Lenovo X200 und Sata für XP

Dieses Thema im Forum "Lenovo Forum" wurde erstellt von Grulei, 26.11.2008.

  1. Grulei

    Grulei Forum Benutzer

    Dabei seit:
    30.10.2008
    Beiträge:
    23
    Zustimmungen:
    0
    Mein Notebook:
    noch nichts eingetragen
    Hallo
    Habe seit einigen Tagen ein X 200 das ich ohne Bertriebssystem neu gekauft habe.
    Habe XP Pro im Kompatibilitätmodus installiert. Installation problemlos, alle Treiber gefunden und installiert. XP läuft einwandfrei.

    Das Problem ist folgendes, wenn ich im Bios versuche den Sata Modus einzustellen kommt nach der Anzeige "Windows wird gestartet" ein Blue Screen.

    Das XP ist am letzten Stand inklusive aller Service Packs.

    Jetzt meine Frage an die Experten: Gibt es die Möglichkeit diesen (anscheinend) fehlenden Sata Treiber in meine bereits fertige XP-Installation einzubinden?

    Bei Anfrage an Lenovo machen es sich die leicht. Ohne Betriebssystem gekauft, kein Support zum Betriebssystem.

    Möglicherweise weiß jemand Rat und kann mir einen Link und eine Installationsanleitung zu meinem Problem geben.
    Vielen Dank im Vorhinein.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort ist für jeden was dabei!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 singapore, 26.11.2008
    singapore

    singapore
    Moderator

    Dabei seit:
    27.01.2007
    Beiträge:
    7.433
    Zustimmungen:
    0
    Ort:
    Good Old Germany ;-)
    Mein Notebook:
    IBM ThinkPad T40
  4. Grulei

    Grulei Forum Benutzer

    Dabei seit:
    30.10.2008
    Beiträge:
    23
    Zustimmungen:
    0
    Mein Notebook:
    noch nichts eingetragen
    Sata-Treiber Win XP

    Also, nach intensiven suchen im Netz habe ich die Antwort selbst gefunden.

    Ich darf vorausschicken das alles ganz einfach geht und perfekt funktioniert. Ich habe soeben die Treiber bei meinem X200 installiert.

    Hier die Anleitng:

    SATA-AHCI-Treiber nachrüsten (Hotline)
    --------------------------------------------------
    c't 26/06, Seite 212, ciw

    **********
    Überarbeitete Version Juni 2008, mit Registry-Einträgen für
    - ICH9-Baureihe
    - ICH10-Baureihe
    - ICH9-Mobile (versuchsweise)
    **********


    AHCI_Trick_22.reg -- Registryeinträge für IaStor.sys

    Den Treiber IaStor.sys bekommt man in der neuesten Version vom Intel-Server, er versteckt
    sich im jeweils aktuellen Storage-Treiber-Paket, das zurzeit (Juni 2008) aktuelle Version 8.2 liegt unter:
    http://downloadmirror.intel.com/16012/eng/iata82_enu.exe

    Das Paket entpackt man nach dem Downlad in ein separates Verzeichnis,
    in diesem Beispiel C:\AHCI, und zwar von der Windows-Eingabeaufforderung aus
    mit dem Befehl:

    IATA82_ENU.exe -a -a -p c:\AHCI

    Nach Bestätigung der Lizenzinformation liegt der entpackte Treiber

    IaStor.sys

    im Verzeichnis

    C:\AHCI\Driver
    (bzw. in C:\AHCI\Driver64);

    von dort aus kopiert man ihn nach

    C:\Windows\System32\Drivers.

    Dann spielt man den Registry-Patch AHCI_Trick_22.reg ein.

    Nach einem Neustart ruft man das BIOS-Setup des Mainboards auf und stellt den AHCI-Betriebsmodus ein. Nach dem Booten
    verlangt Windows den passenden Treiber (IaStor.sys alleine reicht nicht), man verweist den Hardware-Assistenten
    also auf

    C:\AHCI.

    Wer den RAID-Modus oder den sogenannten RAID-Ready-Modus nutzen will (dabei ist zunächst
    kein RAID eingerichtet, lässt sich aber später nachrüsten), kann unter Windows den Intel Matrix Storage Manager
    installieren (IMSM):
    Intel® Matrix Storage Manager - Intel® Matrix Storage Manager support

    Dieser lässt sich mit der erwähnten Datei aus dem Soft-Link einrichten - allerdings
    nur dann, wenn die Southbridge tatsächlich im RAID-Modus läuft (beim ICH8R auch im AHCI-Modus).

    Soweit die Anleitung.
    Die beiden Dateien findet man ganz leicht im Netz.
    Das mit dem Raid habe ich natürlich nicht ausprobiert, aber alles andere funktioniert perfekt.

    Auf die Frage der Vorteile, naja ich weiß nicht, ich habe das Gefühl das die Festplatte noch flotter geht. Werde versuchen das in den nächsten Tagen mit Zahlen zu dokumentieren. Werde dann meine Ergebnisse hier reinstellen.
    Viel Spass
     
  5. Grulei

    Grulei Forum Benutzer

    Dabei seit:
    30.10.2008
    Beiträge:
    23
    Zustimmungen:
    0
    Mein Notebook:
    noch nichts eingetragen
    Benchmark

    Ja, hab die Festplatte mit SiSoft-Sandra (aktuelle Version) getestet.

    Im Compatiblen Modus:
    Lesen und schreiben Durchschnitt: 45000MB
    Im AHCI Modus:
    Lesen und schreiben Durchschnitt: 41000MB
    Also etwa 10% Leistungsverbesserung.
    So das wärs, jeder soll entscheiden ob das hilfreich war.
     
  6. #5 singapore, 26.11.2008
    Zuletzt bearbeitet: 26.11.2008
    singapore

    singapore
    Moderator

    Dabei seit:
    27.01.2007
    Beiträge:
    7.433
    Zustimmungen:
    0
    Ort:
    Good Old Germany ;-)
    Mein Notebook:
    IBM ThinkPad T40
    Danke für die Rückmeldung. Two thumbs up.

    Edit:
    Damit wäre doch der Compatible Modus besser? :confused:
     
  7. Grulei

    Grulei Forum Benutzer

    Dabei seit:
    30.10.2008
    Beiträge:
    23
    Zustimmungen:
    0
    Mein Notebook:
    noch nichts eingetragen
    Denkpause

    Hallo, tut mir leid, vor lauter suchen, probieren usw. habe ich den Überblick verloren.
    Soll natürlich umgekehrt sein.
    Die Platte ist im im AHCI-Modus etwa 10%schneller.
    Dieser Patch sollte auch bei anderen Notebooks mit Intel:Chipset funktinieren.
     
  8. Anzeige

    Auf der Suche nach Notebook-Zubehör?
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

Lenovo X200 und Sata für XP

Die Seite wird geladen...

Lenovo X200 und Sata für XP - Ähnliche Themen

  1. Touchpad für Lenovo X200s

    Touchpad für Lenovo X200s: Hallo, vielleicht ein dummes, unlösbares Problem, trotzdem: Ich habe einen Lenovo X200s gebraucht gekauft. Ich wußte, dass er kein Touchpad,...
  2. Verkaufe Lenovo/IBM X200 12" + Mtron SSD

    Verkaufe Lenovo/IBM X200 12" + Mtron SSD: Hi, Möchte meinen X200 verkaufen den ich nur selten verwendet habe. Gerät ist in einem Top Zustand, keine Dellen, Risse, sieht aus wie neu....
  3. Lenovo X200 Bluetooth Problem

    Lenovo X200 Bluetooth Problem: Hi, habe seit heute meinen ersten lenovo, nun habe ich ihn mit windows 7 neu aufgesetzt da er mit windows vista geliefer wurde. Alles...
  4. Lenovo X200s WLAN-Problem

    Lenovo X200s WLAN-Problem: Hallo! Ich habe mein Lenovo X200s über WLAN und Router mit weiteren Computer, die über LAN angeschlossen sind, vernetzt. Während der Lenovo alle...
  5. Lenovo x200(s)/x300 oder HP 2530p

    Lenovo x200(s)/x300 oder HP 2530p: Hi, ich bin auf der Suche nach einem Subnotebook. Mein Budget betraegt um die 1500. Wichtig waeren mir: Lange Akkulaufzeit (mind. 5 Stunden),...